Laser 28 International Class Association Homepage
Forum Home Forum Home > Laser 28 General > Maintenance
  New Posts New Posts RSS Feed - lack of cooling water flow
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

lack of cooling water flow

 Post Reply Post Reply
Author
Message
Winner View Drop Down
Senior Member
Senior Member
Avatar

Joined: 07 September 2011
Status: Offline
Points: 180
Post Options Post Options   Thanks (0) Thanks(0)   Quote Winner Quote  Post ReplyReply Direct Link To This Post Topic: lack of cooling water flow
    Posted: 20 January 2019 at 10:16am
Hi all,

Haven't been as active as usual in this forum, but have been meaning to post a question about an issue we experienced towards the end of last year.

Basically, the engine at startup would not circulate water through the cooling system.  Nothing appears out of the ordinary.  I have a small inline filter installed just before the muffler that I installed at least 5 years ago.  Right now our solution to the problem is to unscrew the cap of the inline filter which somehow gets the water flowing and then we screw it back on.  I cannot find any blockages in the system.  I also tried tightening all the hose clamps (all connections are double clamped).

Anyone have any thoughts as to the culprit?  
Chris
Eclipse #240
Thunder Bay, ON
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.03
Copyright ©2001-2015 Web Wiz Ltd.

This page was generated in 0.047 seconds.